DNS Record Propagation Degradation

Incident Report for Cyso Cloud

Postmortem

Updates for several DNS records where not propagated upstream, making new changes for those records unavailable on external DNS resolvers.

Due to an issue on our end, this degradation of service was captured too late. Monitoring has been improved to capture more minor degradation of service.

Posted Aug 13, 2026 - 09:46 CEST

Resolved

Updates for several DNS records where not propagated upstream, making new changes for those records unavailable on external DNS resolvers.
Posted Aug 12, 2026 - 09:00 CEST