Issues with Fuga Dashboard
Incident Report for Fuga Cloud
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 22:27 CET
Investigating
We are currently experiencing issues with Fuga Dashboard. Our engineers are investigating the issues. During this time, customers may experience temporary unavailability to login to the dashboard.

We apologize for the inconvenience and will share an update once we have more information.
Posted Nov 27, 2019 - 20:42 CET
This incident affected: Dashboard.