Issues with Fuga Dashboard
Incident Report for Fuga Cloud
Resolved
This incident has been resolved.
Posted Sep 22, 2022 - 11:25 CEST
Investigating
We are currently experiencing issues with Fuga Dashboard. Our engineers are investigating the issues.
Posted Sep 20, 2022 - 18:28 CEST
This incident affected: Portal and Dashboard Services.