Issues with Fuga Dashboard
Incident Report for Fuga Cloud
Resolved
This incident has been resolved.
Posted Nov 27, 2020 - 10:25 CET
Investigating
We are currently investigating this issue.
Posted Nov 27, 2020 - 08:57 CET
This incident affected: Dashboard.